summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2024-06-28 01:04:46 +0200
committerint2024-06-28 01:07:04 +0200
commita55dc20f7df94c3263ba13d54438cda6dbeb248e (patch)
treed0df7b9db3ce8f6ea5e0b5262838f1ebe75ea5e0 /PKGBUILD
downloadaur-perl-parse-ansicolor-tiny.tar.gz
Added Perl/CPAN Module Parse::ANSIColor::Tiny.
This is one of the perl-dependencies of Koha: https://koha-community.org/ Start "./koha_perl_deps.pl -r -a" after downloading and unpacking the koha-tarball for a list of all required packages (version 24.05.00). Koha depedens one perl-html-fromansi-tiny which requires this package, so Koha depends only indirectly from it. PKGBUILD was generated via cpan2aur and the cpan2aur-bugfix was added, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..792a4d71afce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: int <int [ate] arcor [dot] de>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-parse-ansicolor-tiny'
+pkgver='0.700'
+pkgrel='1'
+pkgdesc="Perl/CPAN Module Parse::ANSIColor::Tiny: Determine attributes of ANSI-Colored string"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.006')
+makedepends=()
+checkdepends=('perl-test-differences' 'perl-test-requires')
+url='https://metacpan.org/release/Parse-ANSIColor-Tiny'
+source=("http://search.cpan.org/CPAN/authors/id/R/RW/RWSTAUNER/Parse-ANSIColor-Tiny-$pkgver.tar.gz")
+md5sums=('fc2c7aeadcbbfb755b3bb1db24e807b2')
+sha512sums=('39cc4c4a9401dde3e7133df79eccf1b8e9af444711642b037a29f0d4806838f3cf2924f008d53cd2a21336e401c75b894ef9b583f2c1694ea6835ba00aacfaa5')
+_distdir="Parse-ANSIColor-Tiny-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: