summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Leontiev2014-01-05 13:31:12 +0400
committerAnton Leontiev2015-02-15 07:48:20 +0300
commit1562d6d9175834ff9e1fb2a4215d76771262bb94 (patch)
treed57245a187a68f64c9c9f3040896a2d3da889c5a /PKGBUILD
parentde28905644016669877bf871848e975fd9d0c444 (diff)
downloadaur-perl-pdl-git.tar.gz
Updated to current git revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 21 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aae06a3d7567..bed10df6976d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Anton Leontiev <bunder /at/ t-25.ru>
_pkgname=perl-pdl
pkgname=$_pkgname-git
-pkgver=20130413.3530
+pkgver=20131205.3765
pkgrel=1
pkgdesc='The Perl Data Language, a perl extension designed for scientific and bulk numeric data processing and display'
arch=('i686' 'x86_64')
@@ -9,33 +9,34 @@ url='http://search.cpan.org/dist/PDL'
license=('PerlArtistic' 'GPL')
depends=(
- 'perl>=5.8.9' # To provide ExtUtils::MakeMaker 3.61
- 'perl-inline>=0.43'
- 'gsl'
+ 'perl>=5.8.9'
+ 'perl-inline>=0.43'
+ 'gsl'
)
makedepends=(
- 'fftw2'
- 'hdf4'
- 'perl-opengl>=0.63'
- 'plplot'
- 'perl-extutils-f77'
- 'proj'
+ 'perl>=5.11.3' # To provide ExtUtils::MakeMaker 6.56
+ 'fftw2'
+ 'hdf4'
+ 'perl-opengl>=0.63'
+ 'plplot'
+ 'perl-extutils-f77'
+ 'proj'
)
optdepends=(
- 'fftw2: for PDL::FFTW support'
- 'hdf4: for HDF files support'
- 'perl-astro-fits-header: improved FITS files support'
-# 'perl-convert-uu: for the case when something wrong with Unicode support' # It is necessary on *BSD systems
-# 'perl-extutils-f77: for PDL::Slatec and PDL::Minuit support' # It is not necessary at runtime
- 'perl-opengl>=0.63: for PDL::Graphics::TriD support'
- 'plplot: for PDL::Graphics::PLplot support'
- 'proj: for PDL::GIS::Proj and PDL::Transform::Proj4 support'
+ 'fftw2: for PDL::FFTW support'
+ 'hdf4: for HDF files support'
+ 'perl-astro-fits-header: improved FITS files support'
+# 'perl-convert-uu: for the case when something wrong with Unicode support' # It is necessary on *BSD systems
+# 'perl-extutils-f77: for PDL::Slatec and PDL::Minuit support' # It is not necessary at runtime
+ 'perl-opengl>=0.63: for PDL::Graphics::TriD support'
+ 'plplot: for PDL::Graphics::PLplot support'
+ 'proj: for PDL::GIS::Proj and PDL::Transform::Proj4 support'
)
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$_pkgname::git+git://pdl.git.sourceforge.net/gitroot/pdl/pdl" 'perldl.conf')
-md5sums=('SKIP' '9caa2b89a7f7aabfd7dcfb2c1ef79bc9')
+md5sums=('SKIP' '8e1f6285ce4ee9439dc1088709cfec18')
pkgver() {
cd "$_pkgname"
@@ -44,7 +45,7 @@ pkgver() {
build() {
cd "$_pkgname"
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor PDLCONF=$srcdir/perldl.conf
+ F77LIBS='-lgfortran -lm' PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor PDLCONF=$srcdir/perldl.conf
make
}