summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichal Wojdyla2024-05-05 19:57:25 +0200
committerMichal Wojdyla2024-05-05 19:57:25 +0200
commitbfb85a25ed8281c23a48fd0f52629a8fc0a6e809 (patch)
treef8c5c943061c35b4dcdccc5d9012a3eb23dc7af1 /PKGBUILD
parent80325a3ae736b75308efd2eec3882c8100dde028 (diff)
downloadaur-perl-starlink-ast.tar.gz
Set the shared lib to be root-writable so that it will be stripped.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc9cc77640e1..9dfbf329c3b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='perl-starlink-ast'
pkgver='3.03'
-pkgrel='2'
+pkgrel='3'
pkgdesc="Interface to the Starlink AST library"
arch=('i686' 'x86_64')
license=('GPL-2.0-or-later')
@@ -45,6 +45,8 @@ package() {
cd "$srcdir/$_distdir"
/usr/bin/perl Build install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ # set the library to be root-writable so it can be stripped
+ chmod 755 "$pkgdir"/usr/lib/perl*/*/vendor_perl/auto/Starlink/AST/AST.so
}
# Local Variables: