summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2024-05-05 22:12:54 +0200
committerint2024-05-05 22:12:54 +0200
commit5eeeba5996e86a03449794aa3a228192ef3cbb59 (patch)
tree06d31da0d5704b2b296b36e4174d76880dab7bc5 /PKGBUILD
parentd3e005e43972e19e1736c5e0b0b9db11abf8665b (diff)
downloadaur-perl-string-toidentifier-en.tar.gz
New maintainer: some slight adaptions.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 17 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 338542922f9e..7b70d6a5ef3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
+# Maintainer: int <int [ate] arcor [dot] de>
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-string-toidentifier-en'
pkgver='0.12'
pkgrel='1'
-pkgdesc="Convert Strings to English Program Identifiers"
+pkgdesc="Perl/CPAN Module String::ToIdentifier::EN: Convert Strings to English Program Identifiers"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl-lingua-en-inflect-phrase' 'perl-namespace-clean' 'perl-text-unidecode')
-url='https://search.cpan.org/dist/String-ToIdentifier-EN'
-source=('https://search.cpan.org/CPAN/authors/id/R/RK/RKITOVER/String-ToIdentifier-EN-0.12.tar.gz')
+depends=('perl>=5.8.1' 'perl-lingua-en-inflect-phrase' 'perl-text-unidecode' 'perl-namespace-clean')
+makedepends=()
+url='https://metacpan.org/release/String-ToIdentifier-EN'
+source=("https://search.cpan.org/CPAN/authors/id/R/RK/RKITOVER/String-ToIdentifier-EN-${pkgver}.tar.gz")
md5sums=('2088d00f01974911fa6f8ee169ef80de')
-_distdir="String-ToIdentifier-EN-0.12"
+sha512sums=('1fac41b16d284dacb81412d6f22171d795272f53d18bfe3b048af9bcc11b6844515fb27a389abfabcd18ffd3e6c5cf6905d5e2440a6cd38ef0ea8eda549a43c4')
+_distdir="String-ToIdentifier-EN-${pkgver}"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -38,5 +41,12 @@ package() {
cd "$srcdir/$_distdir"
make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et:
+