summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDamien2018-10-31 21:51:37 +0100
committerDamien2018-10-31 21:51:37 +0100
commitc65e3f2573977be31be171ea17daf1de6f2800be (patch)
tree2b29547f0ad7d787c19dcae0be3dfeb37107d45b /PKGBUILD
parent59080b4dd10f7675c115e8d8c1a78450d79b2caf (diff)
downloadaur-perl-syntax-highlight-perl-improved.tar.gz
clear environment variables
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9db7f3af1e13..2142431c2cde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,6 +28,8 @@ build() {
check() {
cd "${srcdir}/${_distname}-${pkgver}"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1'
make test
}
@@ -35,8 +37,7 @@ package() {
cd "${srcdir}/${_distname}-${pkgver}"
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
make install DESTDIR="${pkgdir}"
- find "$pkgdir" -name .packlist -delete
- find "$pkgdir" -name perllocal.pod -delete
+ find "${pkgdir}" \( -name .packlist -or -name perllocal.pod \) -delete
}
# vim:set ts=2 sw=2 et: