summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMoritz Bunkus2018-09-17 12:47:43 +0200
committerMoritz Bunkus2018-09-17 12:47:43 +0200
commit1121f916e9e260b3e3643b11402f7966067588b2 (patch)
tree38b075145fe06577385e53a2fe00554cf4df7299 /PKGBUILD
parentf65769970f2e3647dc83dcafbbc54eff5af99cba (diff)
downloadaur-perl-sys-sigaction.tar.gz
update to 0.23
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 21 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd35fa74ea0d..3abcee4289e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
-# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Maintainer: Moritz Bunkus <moritz@bunkus.org>
pkgname='perl-sys-sigaction'
-pkgver='0.20'
+pkgver='0.23'
pkgrel='1'
pkgdesc="Perl extension for Consistent Signal Handling"
arch=('any')
@@ -10,37 +9,34 @@ license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
makedepends=()
-url='http://search.cpan.org/dist/Sys-SigAction'
-source=('http://search.cpan.org/CPAN/authors/id/L/LB/LBAXTER/Sys-SigAction-0.20.tar.gz')
-md5sums=('7ca212559c2c514277c4f81039456226')
-sha512sums=('e9a601e59dce17b58f525a6323fe87cca968db1142905eb69167d849039014521115d87ffc594fd67df2ec3072e8fc82aaefbf8671f8c9598c1792f6850c4370')
-_distdir="Sys-SigAction-0.20"
+url="https://metacpan.org/pod/Sys::SigAction"
+source=("https://cpan.metacpan.org/authors/id/L/LB/LBAXTER/Sys-SigAction-${pkgver}.tar.gz")
+sha512sums=('04248c7b055efe15264a05677ab37a217828df518195308b3f46e5c415f8b1aef6578d1b79798ac38e4c9df7323f37ae10ce753189196edb75369bd6ec8ac309')
-build() {
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
- PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/Sys-SigAction-${pkgver}"
+}
- cd "$srcdir/$_distdir"
- /usr/bin/perl Makefile.PL
- make
- )
+build() {
+ prepare_environment
+ /usr/bin/perl Makefile.PL
+ make
}
check() {
- cd "$srcdir/$_distdir"
- ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
- make test
- )
+ prepare_environment
+ make test
}
package() {
- cd "$srcdir/$_distdir"
+ prepare_environment
make install
-
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
}
# Local Variables: