summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcell Meszaros2024-02-13 19:39:50 +0100
committerMarcell Meszaros2024-02-13 19:44:34 +0100
commit7ddb396c48548f16facf57ed94b5b336ff74557e (patch)
tree126682b912b83329073ef6f115592e378b9b89aa /PKGBUILD
parent960cce779edf6b63cc911dca473e889246506277 (diff)
downloadaur-perl-template-plugin-json.tar.gz
0.08-1: upstream update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbf928e1bafa..06b28f582816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,30 @@
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Generator : CPANPLUS::Dist::Arch 1.32
+_distname='Template-Plugin-JSON'
pkgname='perl-template-plugin-json'
-pkgver='0.06'
+pkgver='0.08'
pkgrel='1'
pkgdesc="Adds a .json vmethod for all TT values."
arch=('any')
-license=('PerlArtistic' 'GPL')
+license=('MIT')
options=('!emptydirs')
-depends=('perl-json>=2.12' 'perl-moose' 'perl-template-toolkit')
-makedepends=('perl-test-use-ok')
-url='http://search.cpan.org/dist/Template-Plugin-JSON'
-source=('http://search.cpan.org/CPAN/authors/id/N/NU/NUFFIN/Template-Plugin-JSON-0.06.tar.gz')
-md5sums=('a8ea2961cad97a848741a65caad3dad9')
-sha512sums=('f687434a583e638c7d06cd733376d432353a5c1628d2a5fe0f625a92b3cbe9a9e213d4a5ec42c05f9748ecd17bffd636eed89a92c12b0c1a95d7bfe48fd11d32')
-_distdir="Template-Plugin-JSON-0.06"
+depends=(
+ 'perl'
+ 'perl-json-maybexs'
+ 'perl-moose'
+ 'perl-template-toolkit'
+)
+checkdepends=(
+ 'perl-sub-name'
+ 'perl-yaml'
+)
+url="https://metacpan.org/release/$_distname"
+_author='ETHER'
+source=("https://search.cpan.org/CPAN/authors/id/${_author::1}/${_author::2}/$_author/$_distname-$pkgver.tar.gz")
+sha512sums=('98cdabbbab4781b8c811a0ad4ae6b26f9fbeeb1fcb8d8529b07ce92e8eb617920620721a9b01c3e91bedb60b609c8e04f82ef304a302d6b4a2287a1617e2a5fb')
+_distdir="$_distname-$pkgver"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -39,12 +49,7 @@ check() {
package() {
cd "$srcdir/$_distdir"
make install
-
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
-}
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et:
+ install -Dm644 LICENCE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}