summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 16:08:26 -0600
committerJohn D Jones III2015-06-16 16:08:26 -0600
commit99ea661cdd93b9728a76283d7b52e3fc2751f811 (patch)
treee030824c5d2d89059015ddf3b81167e90bac1de1 /PKGBUILD
downloadaur-perl-text-normalize-naco.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fab18b94588f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-text-normalize-naco'
+pkgver='0.13'
+pkgrel='1'
+pkgdesc="Normalize text based on the NACO rules"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-text-unidecode')
+makedepends=()
+url='http://search.cpan.org/dist/Text-Normalize-NACO'
+source=('http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/Text-Normalize-NACO-0.13.tar.gz')
+md5sums=('f4520a3dca5797b712600e2faa97073a')
+sha512sums=('849ccb0c4d722936a7fbfb727e0bc56dcc7ba90f4f3079f781f68849f56a6c3c0b3e3ac880d00d514b0ecfd56967f10e18747b62a2fb1f8788e749a97d574242')
+_distdir="Text-Normalize-NACO-0.13"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: