summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorint2024-05-01 16:14:52 +0200
committerint2024-05-01 16:14:52 +0200
commitadc8ee90d074e7bc7d0113cdf3606cf2668ae155 (patch)
tree4d92d1b24ede8d86c7cc3631cc4c8533b6e0de74 /PKGBUILD
parentdcfca7b9d58f641b6cb760a8e24618dee1ddee15 (diff)
downloadaur-perl-text-pdf.tar.gz
Apply some patches of the Text-PDF bug-tracker.
The bug-tracker can be found at https://rt.cpan.org/Public/Dist/Display.html?Name=Text-PDF The number in the patch-filename refers to the specific bug-id there. Note: I first apply the patch of bug-id 124350 and afterwards bug-id 123562. So the changes that were already applied from the first patch are not a part of the second one. So the patch in the bug-tracker differs accordingly from bug123562.patch provided in the package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 33 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f009a9f47a4..246415403c7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='perl-text-pdf'
pkgver='0.31'
-pkgrel='1'
+pkgrel='2'
pkgdesc="Perl/CPAN Module Text::PDF: Module for manipulating PDF files"
arch=('any')
license=('PerlArtistic' 'GPL')
@@ -11,10 +11,38 @@ options=('!emptydirs')
depends=('perl')
makedepends=()
url='https://metacpan.org/release/Text-PDF'
-source=('http://search.cpan.org/CPAN/authors/id/B/BH/BHALLISSY/Text-PDF-0.31.tar.gz')
-md5sums=('bf63812e65f2e2012e10e422a637760a')
-sha512sums=('6413bddaefbb57918763d395b9c751ad630a2095970c2c1febb01235343339fd4eae2820a30b449775d95071cca000a0f11e955fe304c2c56a45e80b384308d5')
-_distdir="Text-PDF-0.31"
+source=("http://search.cpan.org/CPAN/authors/id/B/BH/BHALLISSY/Text-PDF-$pkgver.tar.gz"
+ "bug120334.patch"
+ "bug120400.patch"
+ "bug123839.patch"
+ "bug124350.patch"
+ "bug123562.patch"
+)
+md5sums=('bf63812e65f2e2012e10e422a637760a'
+ '7ee42cd37f9adaffc684f69c0744b25c'
+ '5ff27bf82b28fd1ad963f1b2c182de62'
+ '6d0dfe20fb777fffc05221c9d6689bea'
+ '2daa955a773b9d29153c0fe4889ad931'
+ 'bfbe9480b12f45ada057e13fde28c016'
+)
+sha512sums=('6413bddaefbb57918763d395b9c751ad630a2095970c2c1febb01235343339fd4eae2820a30b449775d95071cca000a0f11e955fe304c2c56a45e80b384308d5'
+ 'a809060a6b941e726e1c287c3e722398569e61626e369d8f29ab2813dfb9cd6cba30528f44437970eb7b0cf460b1f8481377fbe19b02df776728b88f4885efd9'
+ '6dc510e50e86b2c9f34e2301cd9229bca2161186bdbceec8ee959938b9aa18eb0c182f61ef8bd96d76d4965c04b544b69ec03ac1ff20d397b70482719bbda32d'
+ '1f3d4096bd365af677dde25d999f274cace5d260ca2f9c2fbdf3726c10ed908e3ce098ec62aade7af78cb4300ca132c3e5537ea0c7917f4e2bfb2d80c7eb0870'
+ '9881616d4ebe47c7849273052896d7bde5d99c9c7a8c2f0761e246215f9e74936cfbf662f3bf2dc2011cbeee0990f8393c90709544cf6370f257a5917fdba945'
+ '9fe63e0ce02aaa3cde7c642fc84a9c69c0617f8d86c8f8a59ca078fabe451216c3232630f8d5a9b40724c1d9237c054affa73c2212cd98fc726f9916d984ebf1'
+)
+_distdir="Text-PDF-$pkgver"
+
+prepare() {
+ cd "$srcdir/$_distdir"
+
+ patch --forward --strip=1 --input=$srcdir/bug120334.patch
+ patch --forward --strip=1 --input=$srcdir/bug120400.patch
+ patch --forward --strip=1 --input=$srcdir/bug123839.patch
+ patch --forward --strip=1 --input=$srcdir/bug124350.patch
+ patch --forward --strip=1 --input=$srcdir/bug123562.patch
+}
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \