summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
committerKrzysztof (3ED) AS2015-07-02 10:03:49 +0200
commit76e755a152cf360c5ac6da3e1dbe3667fb598fcc (patch)
tree9b31ed2b66752ae4a36c91c1fcc48a0fdcc96971 /PKGBUILD
downloadaur-perl-uri-magnet.tar.gz
moving files, making space for additional scripts, aur4 and other stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a25133f1e695
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: 3ED <krzysztof1987 at gmail dot com>
+#
+pkgname=perl-uri-magnet
+_lastauthor=G/GA/GARU
+_pkgname=URI-magnet
+pkgver=0.03
+pkgrel=1
+pkgdesc='Magnet URI scheme'
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-uri')
+makedepends=('perl-extutils-makemaker')
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('02ecc4c54bda97b6f95b50826b4d0a5de29b0dd621a2e7d94367dff8c9a81259')
+
+build() {
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL="--skipdeps" \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd ${_pkgname}-${pkgver}
+ perl Makefile.PL
+ make
+}
+check() {
+ cd ${_pkgname}-${pkgver}
+ make test
+}
+package() {
+ cd ${_pkgname}-${pkgver}
+ make install
+}
+