summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLenni vH2020-09-05 09:59:04 +0200
committerLenni vH2020-09-05 09:59:04 +0200
commita00b300c1b4c9cb0c9ff9cb389b703f35e46ef0f (patch)
treec3b4b71ca224a0d0acf97d91263e09363c44a785 /PKGBUILD
parent30f53cc0887be9ffeb8c046b61135eea573e9501 (diff)
downloadaur-peyote.tar.gz
bump to 0.10.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 079f84a1886e..bb832006089b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
-# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: d0lphin <scrouthtv [at] gmail [dot] com>
+# Contributor: willemw <willemw12@gmail.com>
# Contributor: Andrew Trabo <v01d3r@gmail.com>
pkgname=peyote
-pkgver=0.9.12
-pkgrel=3
+pkgver=0.10.0
+pkgrel=1
pkgdesc="Audio player with a Midnight Commander interface"
url="http://peyote.sourceforge.net/"
arch=('i686' 'x86_64')
license=('GPL3')
-depends=('desktop-file-utils' 'gstreamer0.10-python' 'gtk-update-icon-cache' 'mutagen' 'pygtk' 'python2-dbus' 'python2-pyinotify')
+depends=( 'gst-python' 'python2-mutagen' 'pygtk' 'python2-dbus' 'python2-pyinotify' 'python2-pyalsaaudio')
+#depends=('desktop-file-utils' 'gstreamer-python' 'gtk-update-icon-cache' 'mutagen' 'pygtk' 'python2-dbus' 'python2-pyinotify')
optdepends=('alsa-utils: default mixer (alsamixer)'
'gstreamer0.10-bad-plugins: "Bad" plugin libraries'
'geeqie: default image viewer'
@@ -19,18 +21,18 @@ optdepends=('alsa-utils: default mixer (alsamixer)'
'libnotify: notifications (notify-send)'
'mplayer: default video player'
'rxvt-unicode: default terminal emulator for xpeyote')
-install=$pkgname.install
-source=(http://downloads.sourceforge.net/project/peyote/Linux/${pkgname}_$pkgver.tar.bz2)
-sha256sums=('62180b2ba63b0d99ef27bb7753304c08cf557534f7bab7586dd37fdbe6f9e76f')
+install="$pkgname.install"
+source=(http://downloads.sourceforge.net/project/peyote/Linux/${pkgname}_$pkgver.tar.gz)
+sha256sums=('72acce6c394f57704a91d9621c5cecb766a3490be15d75b2ebcff3457af55497')
build() {
- cd ${pkgname}_$pkgver
+ cd ${pkgname}
PYTHON=/usr/bin/python2 ./configure --prefix=/usr
make
}
package() {
- cd ${pkgname}_$pkgver
+ cd ${pkgname}
install -Dm644 README "$pkgdir/usr/share/$pkgname/README"
make DESTDIR="$pkgdir/" install
}