summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122023-11-28 18:35:08 +0100
committerwillemw122023-11-28 18:35:08 +0100
commit32ed3936733de2624ca4a2cfa4fb605e23e274a8 (patch)
tree4fc93436e4866758bb66af72bd2fb5fd9e0ce141 /PKGBUILD
parent99f4954bc2927ca914dbbb42d4b4d451bc048487 (diff)
downloadaur-pgl-cli.tar.gz
Cleanup arch, conflicts, depends, makedepends
Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD72
1 files changed, 38 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7411f02db2a..be105560cfe2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,56 @@
-# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
pkgname=pgl-cli
pkgver=2.3.1
-pkgrel=1
-pkgdesc='A privacy oriented firewall application (Daemon & CLI).'
-arch=('i686' 'x86_64')
-url='http://sourceforge.net/projects/peerguardian/'
-license=('GPL3')
-depends=('bash' 'systemd' 'dbus' 'coreutils' 'procps-ng' 'logrotate' 'wget' 'iptables' 'libnetfilter_queue')
-optdepends=('unzip: for zipped blocklists'
- 'p7zip: for 7z blocklists'
- 'net-tools: to whitelist local IP addresses'
+pkgrel=2
+pkgdesc='Privacy oriented firewall (daemon and CLI)'
+arch=(x86_64)
+url=https://sourceforge.net/projects/peerguardian
+license=(GPL3)
+depends=(dbus iptables libnetfilter_queue logrotate wget)
+optdepends=('net-tools: to whitelist local IP addresses'
'networkmanager: to whitelist newly started network interfaces'
+ 'p7zip: for 7z blocklists'
'smtp-forwarder: to send reports'
- 'tcptraceroute: to diagnose connection problems')
-makedepends=('zlib')
-provides=('pgl')
-conflicts=('pgl' 'pgl-git')
-backup=('etc/pgl/allow.p2p'
- 'etc/pgl/blocklists.list'
- 'etc/pgl/pglcmd.conf'
- 'etc/logrotate.d/pglcmd'
- 'etc/logrotate.d/pgld')
+ 'tcptraceroute: to diagnose connection problems'
+ 'unzip: for zipped blocklists')
+provides=("${pkgname%-cli}")
+conflicts=("${pkgname%-cli}")
+backup=(etc/logrotate.d/pglcmd
+ etc/logrotate.d/pgld
+ etc/pgl/allow.p2p
+ etc/pgl/blocklists.list
+ etc/pgl/pglcmd.conf)
changelog=changelog
source=("https://downloads.sourceforge.net/project/peerguardian/PeerGuardian%20Linux/$pkgver/pgl-$pkgver.tar.gz"
"pglinux-2.3.1_p20171006-fno-common.patch::https://gitweb.gentoo.org/repo/gentoo.git/plain/net-firewall/pglinux/files/pglinux-2.3.1_p20171006-fno-common.patch?id=492d6119594d1774685fcd4f40fb5d754c3d77c4")
-sha1sums=('a91c0c49cdbf78aa6cc1d93b8ed6843290460520'
- '17b0e89ab5cc9ad9b8ac52823e63f741f5cb6d79')
+sha256sums=('1b5c6d233baa943b42254c95ed2853d036f3f246feaebc073e3c91c05a4c98b4'
+ 'b4cf3cb48620e04c5115be1db73eb25fb9c779120e4930b3e5d4bd04d8c4a13c')
prepare() {
- cd "pgl-$pkgver"
-
- patch -p1 < ../pglinux-2.3.1_p20171006-fno-common.patch
+ cd pgl-$pkgver
+ patch -p1 < ../pglinux-2.3.1_p20171006-fno-common.patch
}
build() {
- cd "pgl-$pkgver"
-
- ./configure --prefix=/usr --sbindir=/usr/bin --sysconfdir=/etc --localstatedir=/var --datarootdir=/usr/share \
- --with-piddir=/run --with-systemd --disable-cron --without-initddir --without-qt4
- make
+ cd pgl-$pkgver
+ ./configure --datarootdir=/usr/share \
+ --disable-cron \
+ --localstatedir=/var \
+ --prefix=/usr \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --with-piddir=/run \
+ --with-systemd \
+ --without-initddir \
+ --without-qt4
+ make
}
package() {
- cd "pgl-$pkgver"
-
- make DESTDIR="$pkgdir" install
+ make -C pgl-$pkgver DESTDIR="$pkgdir" install
- # integrates daemon log in systemd journal
- sed -i '/^LOG_SYSLOG/s/0/1/g' $pkgdir/usr/lib/pgl/pglcmd.defaults
+ # Integrate daemon log in systemd journal
+ sed -i '/^LOG_SYSLOG/s/0/1/g' $pkgdir/usr/lib/pgl/pglcmd.defaults
}