summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJingbei Li2022-08-13 20:28:46 +0800
committerJingbei Li2022-08-13 20:28:46 +0800
commit5862bb170f496c949f8dc28949bc74c7c4748350 (patch)
treed1742424de81b1ccbc7d65f958762f0198234d85 /PKGBUILD
parentd9e07bfb801d49a566775d5ae06cfcb507c54d98 (diff)
downloadaur-pinyin-completion.tar.gz
migrated to python3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea13a648759c..6fd432b37287 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: Petron <petron@archlinuxcn.org>
+# Maintainer: Jingbei Li <i@jingbei.li>
pkgname=pinyin-completion
-pkgver=34.68173f0
+pkgver=56.5feec0b
pkgrel=1
pkgdesc="complete path name based upon the pinyin acronym of Chinese characters"
arch=('any')
url="https://github.com/petronny/pinyin-completion"
license=('GPL3')
-depends=('python2')
+depends=('python')
makedepends=('git')
source=("git+https://github.com/petronny/pinyin-completion"
"pinyin-completion.install")
@@ -21,7 +21,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname/tools"
- python2 table-generator.py > ../pinyin/pinyin_initial.py
+ python table-generator.py > ../pinyin_completion/pinyin_initial.py
}
package() {
@@ -31,5 +31,5 @@ package() {
cp -r shell "$pkgdir/usr/share/$pkgname/"
cp -r tools "$pkgdir/usr/share/$pkgname/"
- python2 setup.py install --root=$pkgdir/ --optimize=1
+ python setup.py install --root=$pkgdir/ --optimize=1
}