summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcaltlgin2020-08-28 18:19:51 +1200
committercaltlgin2020-08-28 18:19:51 +1200
commit9041ba70974439c30241280f75a4d7482b5349df (patch)
treebf6464933e5f393fef973117fc2e270d3eaa1190 /PKGBUILD
parent187cd944cb620c86f7c70b344cef6c9924e5c431 (diff)
downloadaur-piu-piu-sh-git.tar.gz
Adopt and fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 20 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 880a415a6dcb..c5b6c5aec971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: kusakata <shohei atmark kusakata period com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: kusakata <shohei atmark kusakata period com>
-pkgname=piu-piu-sh-git
-pkgver=r223.6fc9547
+_pkgname='piu-piu'
+pkgname="${_pkgname}-sh-git"
+pkgver=r373.4ecf0ea
pkgrel=1
-pkgdesc="Old School horizontal scroller 'Shoot Them All' game in bash"
+pkgdesc='Old School horizontal scroller "Shoot Them All" game in bash'
arch=('any')
-url="https://github.com/vaniacer/piu-piu-SH"
-license=("MIT")
-provides=('piu-piu-sh')
-conflicts=('piu-piu-sh')
-depends=('bash' 'ncurses')
+url='https://github.com/vaniacer/piu-piu-SH'
+license=('MIT')
makedepends=('git')
-source=("git+https://github.com/vaniacer/piu-piu-SH")
-sha1sums=('SKIP')
+optdepends=('netcat: multiplayer mode')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}-sh")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/piu-piu-SH"
+ cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "${srcdir}/piu-piu-SH"
- sed -n '/License/,/SOFTWARE\./p' piu-piu > LICENSE
-}
-
package() {
- cd "${srcdir}/piu-piu-SH"
- install -Dm755 piu-piu "${pkgdir}/usr/bin/piu-piu"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${_pkgname}"
+ install -Dm755 -t "${pkgdir}/usr/bin" "${_pkgname}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
+ install -Dm644 'LICENSE.md' "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
+
+# vim: ts=2 sw=2 et: