summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOrhun Parmaksız2022-10-16 01:50:40 +0300
committerOrhun Parmaksız2022-10-16 01:50:40 +0300
commita3ec6685cb780739e72a9083e20fe8fbd05eb2f2 (patch)
tree3efcf877845550b670f1f6c96e0bd31af397aa0e /PKGBUILD
parentcfc17a88d39256b75bb885227ad76e13790b424e (diff)
downloadaur-a3ec6685cb780739e72a9083e20fe8fbd05eb2f2.tar.gz
upgpkg: pkgtop-git 2.4.1.r0.g960d88d-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ff34e21fb69..1c0313e82ce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
pkgname=pkgtop-git
pkgdesc="Interactive package manager & resource monitor (git)"
-pkgver=2.4.r0.g639b2fe
-pkgrel=2
+pkgver=2.4.1.r0.g960d88d
+pkgrel=1
arch=('x86_64')
url="https://github.com/orhun/pkgtop"
license=('GPL3')
+depends=('glibc')
makedepends=('git' 'go')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
@@ -20,7 +21,7 @@ pkgver() {
}
build() {
- cd "${pkgname%-git}/src"
+ cd "${pkgname%-git}/cmd"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -30,7 +31,7 @@ build() {
}
package() {
- cd "${pkgname%-git}/src"
+ cd "${pkgname%-git}/cmd"
install -Dm 755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
install -Dm 644 "../README.md" -t "$pkgdir/usr/share/doc/$pkgname"
}