summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorC. Dominik Bódi2019-09-26 09:43:57 +0200
committerC. Dominik Bódi2019-09-26 09:43:57 +0200
commit09cbe64d6dbe9c79bce05bfff641e9d6696bed6e (patch)
tree5688113d346a8453df5226e234200a4d0b79906e /PKGBUILD
parent73d4480c879e282f2105c5bce233d74a4348984c (diff)
downloadaur-pkhex.tar.gz
* updated to upstream releave 19.09.19
* changed source download from git to release tarball
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dccaf6ef7662..ee6f67f76d37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: jtmb <packaging at technologicalwizardry dot com>
_pkgname=PKHeX
pkgname=pkhex
-pkgver=19.08.19
+pkgver=19.09.19
pkgrel=1
pkgdesc="Pokémon core series save editor, programmed in C#."
arch=(any)
@@ -13,11 +13,13 @@ makedepends=(git msbuild)
provides=(pkhex)
conflicts=(pkhex-bin pkhex-git)
options=('!strip')
-source=("git+https://github.com/kwsch/PKHeX#tag=${pkgver}"
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/kwsch/PKHeX/archive/${pkgver}.tar.gz"
"PKHeX.sh"
"PKHeX.desktop"
"PKHeX.png")
-md5sums=('SKIP'
+# "git+https://github.com/kwsch/PKHeX#tag=${pkgver}"
+
+md5sums=('7907f0f7cb989f1cbc709367e5694b94'
'20361d8321bf7f2ff35d6f29dea4764d'
'dc5fb6d9abadcaf7759ecb5b02850e4b'
'ceb97fc5efcf4548ca4572b5116f5875')
@@ -25,7 +27,7 @@ backup=("opt/${_pkgname}/PKHeX.exe.config"
"opt/${_pkgname}/PKHeX.Core.dll.config")
build() {
- cd "${_pkgname}"
+ cd "${_pkgname}-${pkgver}"
msbuild PKHeX.sln -t:restore -t:build -p:Configuration=Mono-Release
@@ -36,7 +38,7 @@ package() {
install -Dm644 "${_pkgname}.desktop" "$pkgdir/usr/share/applications/${_pkgname}.desktop"
install -Dm644 "${_pkgname}.png" "$pkgdir/usr/share/pixmaps/${_pkgname}.png"
install -Dm755 -- PKHeX.sh "$pkgdir/usr/bin/${_pkgname}"
- cd "${_pkgname}"
+ cd "${_pkgname}-${pkgver}"
install -Dm755 -- PKHeX.WinForms/bin/Mono-Release/PKHeX.exe "$pkgdir/opt/${_pkgname}/PKHeX.exe"
install -Dm644 -- PKHeX.WinForms/bin/Mono-Release/PKHeX.exe.config "$pkgdir/opt/${_pkgname}/PKHeX.exe.config"