summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Price2016-01-09 21:38:06 +0000
committerWill Price2016-01-09 21:38:17 +0000
commit1f10bba337f565c4c278a2470da5c0200e9d908b (patch)
tree8a5e04d42e52c594f21c713b003ddb6f5aab4974 /PKGBUILD
parent0e94a09269fcf2e98269b89da9301ec8f46dd792 (diff)
downloadaur-1f10bba337f565c4c278a2470da5c0200e9d908b.tar.gz
Integrate updates from bricewge
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 20 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 905d32d9b604..b968324a46dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
# Maintainer: Will Price <will.price94+aur@gmail.com>
+# Contributor: Brice Waegeneire <bricewge at gmail dot com>
+
pkgname=platformio-git
-pkgver=20140913
+pkgver=v2.1.1.r554.g3d0aad6
pkgrel=2
pkgdesc="A cross-platform code builder and library manager"
-arch=('x86_64' 'i686')
-url="http://platformio.ikravets.com/"
+arch=('any')
+url="http://platformio.com/"
license=('GPL')
-groups=()
-depends=('python2' 'python2-click' 'python2-bottle')
-makedepends=()
-checkdepends=()
+depends=('python2'
+ 'python2-click-5.1'
+ 'python2-bottle'
+ 'python2-lockfile'
+ 'python2-requests'
+ 'python2-colorama'
+ 'python2-pyserial')
optdepends=('energia: For MSP430 based projects'
'arduino: For Arduino based projects')
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=('git+https://github.com/ivankravets/platformio.git')
md5sums=('SKIP')
-noextract=()
+
+pkgver() {
+ cd "${pkgname%%-git}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
- cd "$srcdir/${pkgname%%-git}"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/${pkgname%%-git}"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
}