summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Price2017-09-16 11:11:14 +0100
committerWill Price2017-09-16 11:11:14 +0100
commitfa561f8289fbe712a8c36e0a2c632af88dc39331 (patch)
treeb080a9e7912a10bd0f5721f8d5cb824937858c79 /PKGBUILD
parent0abbdeb00826978f4595c53348f1e8312c78486f (diff)
downloadaur-fa561f8289fbe712a8c36e0a2c632af88dc39331.tar.gz
Depend on python2-arrow, update to platformio-core repo
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48e42b22c50f..d44f1cc3f7f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,15 @@
# Contributor: Brice Waegeneire <bricewge at gmail dot com>
pkgname=platformio-git
-pkgver=v2.8.6.r596.g0f300a2
-pkgrel=3
+_pkgname=platformio-core
+pkgver=v3.3.0.r296.gaa1c7609
+pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
-url="http://platformio.com/"
+url="http://platformio.org/"
license=('GPL')
depends=('python2'
+ 'python2-arrow'
'python2-bottle'
'python2-click-5.1'
'python2-colorama'
@@ -18,15 +20,15 @@ depends=('python2'
'python2-semantic-version')
optdepends=('energia: For MSP430 based projects'
'arduino: For Arduino based projects')
-source=('git+https://github.com/ivankravets/platformio.git')
+source=('git+https://github.com/platformio/platformio-core.git')
md5sums=('SKIP')
pkgver() {
- cd "${pkgname%%-git}"
+ cd "${_pkgname}"
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/${pkgname%%-git}"
+ cd "$srcdir/${_pkgname}"
python2 setup.py install --root="$pkgdir/" --optimize=1
}