summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2014-03-17 19:05:17 +0100
committerCarsten Teibes2014-03-17 19:05:17 +0100
commitd6a5a6d1fa8cee60eb108f133f8090ff9d89dabf (patch)
tree2bc66898c17178497ed6cb19cf2257d44ef26c02 /PKGBUILD
downloadaur-plee-the-bear.tar.gz
[add] plee-the-bear 0.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed984f5655c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
+# Contributor: Ronan Rabouin <darkbaboon@gmail.com>
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+pkgname=plee-the-bear
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="A classic 2D platform game - rescue your kidnapped son (to slap him)."
+arch=('i686' 'x86_64')
+url="http://www.stuff-o-matic.com/plee-the-bear/?lang=en"
+license=('GPL' 'CCPL: by-sa')
+depends=('libclaw' 'sdl2_mixer' 'wxgtk2.8' 'desktop-file-utils' 'boost-libs')
+makedepends=('cmake' 'boost' 'docbook-to-man')
+install=$pkgname.install
+source=($pkgname-$pkgver-light.tar.gz::"http://www.stuff-o-matic.com/plee-the-bear/download/file.php?platform=source")
+sha256sums=('41dfe864fe2d791d6f99ba7cd330e22c94fce19d82909054eeac594aa4f2924e')
+
+build() {
+ cd $pkgname-$pkgver-light
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=release \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-2.8 \
+ -DBEAR_EDITORS_ENABLED=TRUE # FALSE for no wx dependency
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver-light
+
+ make DESTDIR="$pkgdir/" install
+}