summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreNV252022-04-09 12:39:04 +0530
committereNV252022-04-09 12:39:04 +0530
commit0256f9d417730255269dacab9518b2a337c32d1a (patch)
treef65ae0044117487509f0a1ac36000482ceb8a2c7 /PKGBUILD
parent1d705b4ab00176650735e25f66ab6cc623f2401d (diff)
downloadaur-plexdrive.tar.gz
upgpkg: plexdrive 5.2.1-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 18 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7dd129395523..ded2b63852f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,32 @@
# Maintainer: Axel Gembe <derago@gmail.com>
pkgname=plexdrive
-pkgver=5.1.0
+pkgver=5.2.1
pkgrel=1
-pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.'
-arch=('any')
-url='https://github.com/dweidenfeld/plexdrive'
+pkgdesc='Plexdrive mounts your Google Drive FUSE filesystem (optimized for media playback)'
+arch=('x86_64' 'aarch64')
+url='https://github.com/plexdrive/plexdrive'
license=('MIT')
depends=('fuse')
-makedepends=(
- 'go'
- 'git'
-)
+makedepends=('go')
provides=("$pkgname")
conflicts=("$pkgname")
-source=(https://github.com/dweidenfeld/plexdrive/archive/5.1.0.tar.gz)
-sha256sums=('4fa3afc59edcd4ba1917e32af8b0202b9ab7256541c54e417b591d7fd54c632e')
+source=("https://github.com/plexdrive/plexdrive/archive/$pkgver.tar.gz")
+sha256sums=('37d64c4c201419054d33b0313c70e79c53bb55e3c6d35eabdebc43b634c41100')
-prepare() {
- mkdir -p gopath/src/github.com/dweidenfeld
- ln -rTsf $pkgname-$pkgver gopath/src/github.com/dweidenfeld/$pkgname
- export GOPATH="$srcdir"/gopath
+build() {
+ cd "$pkgname-$pkgver/"
- cd gopath/src/github.com/dweidenfeld/$pkgname
- go get -v
-}
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
-build() {
- export GOPATH="$srcdir"/gopath
- cd gopath/src/github.com/dweidenfeld/$pkgname
- go build \
- -trimpath \
- -o $pkgname \
- .
+ pwd
+ go build
}
package() {
- cd $pkgname-$pkgver
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd "$pkgname-$pkgver/"
+ install -Dm755 plexdrive "$pkgdir"/usr/bin/plexdrive
}