summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSýlvan Heuser2024-02-21 08:19:58 +0100
committerSýlvan Heuser2024-02-21 08:19:58 +0100
commitb909bc7f3ab3242cb6fa9ecd7c41d61100e2ba20 (patch)
tree9eb9b2220be47261a21628768aedef0f2e074755 /PKGBUILD
parent8c91173701991c12e33dd24f9c332d86e84067c9 (diff)
downloadaur-pol-git.tar.gz
upgpkg: pol-git r112.1c5aef5-1
Update to Python 3, fix missing license and a few packaging mistakes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 7 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index be1eee8a6a22..07f28b882691 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=pol-git
_pkgname=poline
-pkgver=r23.465d3bf
+pkgver=r112.1c5aef5
pkgrel=1
pkgdesc='Awk-like one-liners for Python'
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/riolet/poline"
license=('MIT')
-depends=('python2')
-makedepends=('git' 'python2')
+depends=('python' 'python-setuptools')
+makedepends=('git')
+options=(!emptydirs)
source=("$_pkgname::git+https://github.com/riolet/poline.git")
sha256sums=('SKIP')
@@ -21,14 +22,10 @@ pkgver () {
)
}
-build() {
- cd "$srcdir/$_pkgname"
- make
-}
-
package() {
cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir" PREFIX='/usr' install
+ install -D -m 644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir/" --optimize=1
}
# vim:set ts=2 sw=2 et: