summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Ogilvy2021-01-04 02:39:31 +0000
committerStephen Ogilvy2021-01-04 02:39:31 +0000
commit59f87dc2bfd6ee48e4d3398ab6e04031ad4cf9b2 (patch)
tree7d6ffec457663ad50de27561a0a75a7a17b81ef7 /PKGBUILD
downloadaur-pomeron-gtk-theme-git.tar.gz
added PKGBUILD and .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c0dbb1896cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Stephen Ogilvy <hypernormalisation at tuta dot io>
+pkgname=pomeron-gtk-theme-git
+pkgver=20210104.05060ea
+pkgrel=1
+pkgdesc="Dark, red GTK theme for GNOME desktops"
+arch=('any')
+url="https://github.com/hypernormalisation/Pomeron-GTK"
+license=('GPL')
+depends=('gtk-engine-murrine' 'gtk-engines' 'gtk3')
+makedepends=('git')
+optdepends=('tela-circle-icon-theme-git: pairs well with this icon theme')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!strip')
+source=("${pkgname%-git}::git+https://github.com/hypernormalisation/Pomeron-GTK")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/pomeron-gtk-theme"
+ local date=$(date --date "$(git show -s --format=%ci)" +%Y%m%d)
+ local commit=$(git rev-parse --short HEAD)
+ echo $date.$commit
+}
+
+package() {
+ DESTDIR="$pkgdir/usr/share/themes"
+ mkdir -p "$DESTDIR"
+ cd "$srcdir"
+ cp -r pomeron-gtk-theme "$DESTDIR/"
+}