summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorİ. Göktuğ Kayaalp2021-07-10 23:50:00 +0300
committerİ. Göktuğ Kayaalp2021-07-10 23:50:00 +0300
commit41bb106ae789c53f10efe97a7f55b3255c82b467 (patch)
tree94283969934a0496f9867f2715835bf7b905478b /PKGBUILD
parent389e226e3ce628a8997899d6f851b8978f0d1c17 (diff)
downloadaur-pomodorino.tar.gz
add optdepends gnome-shell-extension-appindicator
This is needed for showing the app indicator on Gnome 3 / 40.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 17 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a4bbe393f93d..d5d055491bae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,30 @@
# PKGBUILD for pomodorino
# Maintainer: Göktuğ Kayaalp <self at gkayaalp dot com>
+
+# _NOTE FOR GNOME 3 / 40_: by default, Gnome does not support
+# AppIndicators, i.e. system tray icons. Because Pomodorino's main
+# interface currently is an AyatanaAppIndicator and it's associated
+# menu.
+#
+# In order to mitigate this, you can install the optional dependency
+# `gnome-shell-extension-appindicator`, run the following command
+#
+# $ gnome-extensions enable appindicatorsupport@rgcjonas.gmail.com
+#
+# and finally log out and log back in to get Gnome to display the
+# indicators.
+
pkgname=pomodorino
pkgver=0.2.0a1
-pkgrel=2
+pkgrel=3
pkgdesc="a lightweight, simple Pomodoro timer system tray app"
arch=('any')
url=https://github.com/cadadr/pomodorino
license=('GPL')
depends=('python-gobject' 'python-notify2' 'dbus-python'
'libindicator-gtk3' 'libappindicator-gtk3')
+optdepends=('gnome-shell-extension-appindicator: show tray icon on Gnome')
makedepends=('python-setuptools' 'pandoc' 'gettext')
source=("$pkgname-$pkgver.tar.gz::https://github.com/cadadr/pomodorino/archive/refs/tags/v${pkgver}.tar.gz")
@@ -26,3 +41,4 @@ package() {
export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}
+