summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarl Smedstad2024-02-13 22:50:43 +0100
committerCarl Smedstad2024-02-13 22:50:43 +0100
commit5de9239972c27dabfcadddc5a1d5fb37d1828bb1 (patch)
treedb30be12d2082b1a15ca0439e3627dd430b19420 /PKGBUILD
parentcf6090be4d11bdc0cae16c2d9c64137a8805367b (diff)
downloadaur-postlight-parser.tar.gz
upgpkg: 2.2.3-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80f3b7dcd16b..a492e785e61b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Carl Smedstad <carl.smedstad at protonmail dot com>
# Contributor: Hao Long <aur@esd.cc>
-pkgname=mercury-parser
-_name=parser
+pkgname=postlight-parser
+_pkgname=parser
pkgver=2.2.3
-pkgrel=2
+pkgrel=3
pkgdesc="Extract meaningful content from the chaos of a web page (@postlight version)"
arch=(any)
url="https://github.com/postlight/parser"
@@ -14,8 +14,9 @@ makedepends=(
git
npm
)
-
-source=("https://registry.npmjs.org/@postlight/$_name/-/$_name-$pkgver.tgz")
+conflicts=(mercury-parser)
+replaces=(mercury-parser)
+source=("https://registry.npmjs.org/@postlight/$_pkgname/-/$_pkgname-$pkgver.tgz")
noextract=("$pkgname-$pkgver.tgz")
sha256sums=('1aeea735458b89956608a0b3231d882cee73a3319f9bc10a6332b9ad553e829b')
@@ -23,10 +24,10 @@ package() {
npm install -g \
--cache "$srcdir/npm-cache" \
--prefix "$pkgdir/usr" \
- "$srcdir/$_name-$pkgver.tgz"
+ "$srcdir/$_pkgname-$pkgver.tgz"
install -Dm644 -t "$pkgdir/usr/share/doc/$pkgname" \
- "$pkgdir/usr/lib/node_modules/@postlight/$_name/"*.md
+ "$pkgdir/usr/lib/node_modules/@postlight/$_pkgname/"*.md
# npm gives ownership of ALL FILES to build user
# https://bugs.archlinux.org/task/63396