summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAliaksandr Stelmachonak2020-07-25 11:13:25 -0400
committerAliaksandr Stelmachonak2020-07-25 11:13:25 -0400
commitbf45dadfad4a651941c18e3476811ebd0a522776 (patch)
tree9e1a0cc35d723800b07333dcbcfd57d7b228ee0d /PKGBUILD
parentb490577f624d9d332d0c5fdf5aa1a0263769b80a (diff)
downloadaur-powerline-fonts-git.tar.gz
Updated dependencies and cleaned PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 12 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c8ef94b02efb..dbd78d62d920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,40 @@
# Maintainer: Devin Christensen <quixoten at gmail dot com>
+# Maintainer: Aliaksandr Stelmachonak <mail at ava1ar dot me>
pkgname=powerline-fonts-git
-pkgver=r100.a44abd0
-pkgrel=3
-pkgdesc="Powerline fonts for X11 and the console"
+pkgver=r202.e80e3eb
+pkgrel=1
+pkgdesc="Patched fonts for Powerline users"
arch=('any')
url='https://github.com/powerline/fonts'
license=('CPL')
-depends=(fontconfig xorg-font-utils )
+depends=('fontconfig' 'xorg-mkfontscale')
makedepends=('git')
-provides=(ttf-hack)
+provides=(
+ powerline-fonts
+ ttf-hack
+)
conflicts=(
- monaco-powerline-font-git
+ powerline-fonts
otf-droid-sans-mono-powerline-git
- otf-droidsansmono-powerline-git
otf-fura-mono-powerline-git
otf-inconsolata-dz-powerline-git
otf-inconsolata-g-powerline-git
otf-inconsolata-powerline-git
- otf-meslo-powerline-git
otf-sauce-code-powerline-git
- otf-source-code-pro-powerline-git
- powerline-fonts
- source-code-pro-fonts-powerline
- terminess-powerline-font
terminess-powerline-font-git
ttf-anonymice-powerline-git
- ttf-anonymous-pro-powerline
- ttf-anonymous-pro-powerline-git
ttf-dejavu-sans-mono-powerline-git
- ttf-dejavusansmono-powerline-git
ttf-droid-sans-mono-dotted-powerline-git
ttf-droid-sans-mono-slashed-powerline-git
ttf-hack
ttf-hack-powerline-git
- ttf-inconsolata-dz-powerline
- ttf-liberation-mono-powerline-git
ttf-literation-mono-powerline-git
- ttf-meslo-powerline-git
ttf-monofur-powerline-git
- ttf-powerline-fonts-git
- ttf-roboto-mono-powerline-git
ttf-ubuntu-mono-derivative-powerline-git
- ttf-ubuntu-mono-powerline-git
)
-install=$pkgname.install
+install=${pkgname}.install
source=('git+https://github.com/powerline/fonts.git')
-md5sums=('SKIP')
+sha1sums=('SKIP')
pkgver() {
cd fonts