summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDevin Christensen2016-04-07 11:14:06 -0600
committerDevin Christensen2016-04-07 11:25:26 -0600
commitcacaf6ba03c1f7c6bad322fa65f8790b987d158c (patch)
tree6e88478c0f8edca2a57fd029856262c0d268d672 /PKGBUILD
downloadaur-ppd-dell-b2375dfw.tar.gz
Create ppd-dell-b2375dfw package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2306c7c2d0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Devin Christensen <quixoten@gmail.com>
+pkgname=ppd-dell-b2375dfw
+pkgver=A00
+pkgrel=1
+pkgdesc="CUPS Printer Driver for Dell B2375dfw"
+arch=("any")
+url="http://www.dell.com/support/home/us/en/19/product-support/product/dell-B2375dfw/drivers?os=ln90"
+license=("custom")
+source=("http://downloads.dell.com/FOLDER01816495M/1/Printer_B2375_Driver_Dell_${pkgver}_Linux.tar.gz")
+md5sums=('46de00a5cf7856eac33800dd61a6ed26')
+
+package() {
+ cd "cdroot/Linux/noarch"
+
+ install -D -m644 \
+ "eula/eula.htm" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -D -m644 \
+ "at_opt/share/ppd/Dell_B2375dfw_Mono_MFP.ppd" \
+ "${pkgdir}/usr/share/ppd/cupsfilters/Dell_B2375dfw_Mono_MFP.ppd"
+}