summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorben2020-06-17 22:26:40 +0200
committerTorben2020-06-17 22:26:40 +0200
commitd02fbd69266029d78a9936650a15fec4116d00c4 (patch)
tree86799dc3f31a7cf1c5e1abc4e5373a51b0b26a9f /PKGBUILD
parent633f044ff0ecba83aad84f52a86910ecdfb6f1ef (diff)
downloadaur-d02fbd69266029d78a9936650a15fec4116d00c4.tar.gz
Add modification to build processing4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD55
1 files changed, 28 insertions, 27 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 395558ce2aee..552bac28c088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,51 @@
# Maintainer: Torben <git at letorbi dot com>
-# Contributor: lesto <mombelli.mauro at gmail dot com>
-# Contributor: Antonio Rojas <arojas at archlinux dot org>
-# Contributor: Alexander F. Rødseth <xyproto at archlinux dot org>
-pkgname=processing-jdk8
-pkgver=3.5.4
-pkgrel=3
+pkgname=processing4-git
+pkgver=r1.3cd8898
+pkgrel=1
arch=(x86_64)
-pkgdesc='Programming environment for creating images, animations and interactions (always uses Oracle JDK 8)'
+pkgdesc='Programming environment for creating images, animations and interactions'
url='https://www.processing.org/'
license=(GPL LGPL)
-provides=(processing)
-conflicts=(processing processing-bin)
-depends=('jdk8' 'libgl')
+conflicts=(processing processing-bin processing-jdk8)
+depends=('jdk11-openjdk' 'java11-openjfx' 'jogl' 'libgl')
makedepends=('ant' 'gendesk' 'unzip')
options=(!strip)
-# The Processing version scheme for the 3.5.x series uses a special magical
-# version number above 0266 in addition to the ordinary version number.
-source=("https://github.com/processing/processing/archive/processing-0$((266+${pkgver##3.5.}))-$pkgver.tar.gz"
- 'https://download.processing.org/reference.zip'
- always_use_java-8-jdk.patch
+source=('https://download.processing.org/reference.zip'
+ always_use_java-11-openjdk.patch
derive_jdk_from_path.patch
disable_update_check.patch
- no_downloads.patch)
-sha256sums=('99a5d3cfccd106e79fe82cafa66b72b15c19e5747eac77e40dd0a82b032c2925'
- '2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
- '8255ba154118884e51e3b9b7174814f7de8fcf7c380ce6f8666192adb6f2483c'
+ no_downloads.patch
+ use_system_libraries.patch)
+sha256sums=('2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
+ '66e87536b740194954670c482d698fc3183995bf48f580078511d50d1a3f0323'
'fcd5c5ea558ceadde3f840522a5c1cb11e26569aec651e8154194cca39026611'
'35c4538e6e57c0ea296c6cea590cabeb2b0772f9a431838df270dcc581321e30'
- '52bdda3ce6368df469172889c53091f7284806e2a1524b012e236736de98f646')
+ 'a07184b87d3d2ccd35525a0721df787973f92487bae367a0668abd3f64134263'
+ 'db6d31c42c13f41b2fde531018927d994c4ae13a04848c4afb0762620b0f0903')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
prepare() {
- gendesk -f -n --pkgname=processing --pkgdesc="$pkgdesc"
+ # The size of a full clone is more than 1GB, so we just make a shallow clone
+ git clone --depth 1 https://github.com/processing/processing4.git $pkgname
- # Symbolic link for not having to repeat the revision number
- ln -sf "processing-processing-"*"-$pkgver" $pkgname
+ # Create .desktop file
+ gendesk -f -n --pkgname=processing --pkgdesc="$pkgdesc"
# Copy reference.zip to the java directory
mkdir -p $pkgname/java
- cp "$srcdir/reference.zip" $pkgname/java/
+ cp reference.zip $pkgname/java/
# Create missing directories
mkdir -p $pkgname/build/linux/work/java
# Don't download any files during Ant's build process
patch $pkgname/build/build.xml < no_downloads.patch
+ patch $pkgname/core/build.xml < use_system_libraries.patch
# Disable update check in default preferences
patch $pkgname/build/shared/lib/defaults.txt < disable_update_check.patch
@@ -52,14 +53,14 @@ prepare() {
# Derive JDK location from java binary found in PATH
patch $pkgname/build/linux/processing < derive_jdk_from_path.patch
- # Always use Oracle's JDK to run processing
- patch $pkgname/build/linux/processing < always_use_java-8-jdk.patch
+ # Always use OpenJDK 11 to run processing
+ patch $pkgname/build/linux/processing < always_use_java-11-openjdk.patch
}
build() {
cd "$pkgname/build"
- PATH="/usr/lib/jvm/java-8-jdk/bin/:$PATH" ant build
+ PATH="/usr/lib/jvm/java-11-openjdk/bin/:$PATH" ant build
}
package() {