summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorben2020-06-10 16:43:59 +0200
committerTorben2020-06-10 23:41:57 +0200
commitedb0aa200c8ec70cae8a5c63edc4c66b23c974f0 (patch)
treee3d86d6911290a3d35fe084092b0d59a7a8dbd73 /PKGBUILD
parentaa0929132030c3d7bf4c6bc07ce5f44944ab36bd (diff)
downloadaur-edb0aa200c8ec70cae8a5c63edc4c66b23c974f0.tar.gz
Patch only necessary parts of the build process
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab6d722289b2..d4e56c95decc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,12 +19,12 @@ install=openjdkmsg.install
# https is not available for reference.zip.
source=("https://github.com/processing/processing/archive/processing-0$((266+${pkgver##3.5.}))-$pkgver.tar.gz"
'https://download.processing.org/reference.zip'
- build.xml
- errormessage.patch)
+ errormessage.patch
+ no_downloads.patch)
sha256sums=('99a5d3cfccd106e79fe82cafa66b72b15c19e5747eac77e40dd0a82b032c2925'
'2014fdb12f979f79c624acc514c14ce318f07cb2cc15a63e1b4febaff733f2a5'
- '9f4050475b3363eb5e966fa891caea0391b3dcc2cdb68245f1a053b0d7ffb220'
- 'c6e9609c514730105aab1ee9786f89488e9f49509158743ab1dbea21c1378dcf')
+ 'c6e9609c514730105aab1ee9786f89488e9f49509158743ab1dbea21c1378dcf'
+ 'e3490e4276d1bd33a00d8accad3d72500519477f8aca44703045d92faa342cf6')
prepare() {
gendesk -f -n --pkgname=processing --pkgdesc="$pkgdesc"
@@ -54,8 +54,8 @@ prepare() {
sed 's| java| _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=gasp" java|g' \
-i $pkgname/build/linux/processing
- # Use a custom build.xml file for ant
- cp -fv build.xml $pkgname/build/build.xml
+ # Don't download any files during Ant's build process
+ patch $pkgname/build/build.xml < no_downloads.patch
}
build() {