summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVíctor Castillo2021-04-11 21:47:25 +0200
committerVíctor Castillo2021-04-11 21:47:25 +0200
commit67c86933d24f1ba6b0696a5c20697bd5eb9a47b9 (patch)
tree57357c063145238a07260fa958542594fb091205 /PKGBUILD
downloadaur-program-shell-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daa47a309771
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: castillo055
+pkgname=program-shell-git # '-bzr', '-git', '-hg' or '-svn'
+pkgver=r6.55cd858
+pkgrel=1
+pkgdesc=""
+arch=('any')
+url="https://github.com/castillo055/program-shell/"
+license=('unknown')
+groups=()
+depends=()
+makedepends=('git'
+ 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+backup=()
+options=()
+install=
+source=('git+https://github.com/castillo055/program-shell#branch=main')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake .
+ cmake --build . --target program_shell
+}
+
+check() {
+ cd "$srcdir/${pkgname%-git}"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ cmake --install . --target program_shell --prefix "$pkgdir/usr/"
+}