summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsickcodes2022-09-14 00:47:05 +0000
committersickcodes2022-09-14 00:47:05 +0000
commitab6f2ae69d236fdd016eb69c5071e6e5c583cd9a (patch)
tree58eee34b9d6bac7bd2b665b92b02d079e2494ed0 /PKGBUILD
parentfda3c71b7c2272373cdd6841edd93b7c2130e6fa (diff)
downloadaur-protocase-designer.tar.gz
Update to https://github.com/sickcodes/aur/commit/1325972474220b9194629c8cce34ba1443663d34
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2150020ad9da..d84b70803a15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Sick Codes <info at sick codes>
+# Maintainer: Sick Codes <info@sick.codes>
# Contributor: Benjamin Denhartog <ben@sudoforge.com>
# Contributor: Wayne Hartmann (DH4) <wayne@bitstorm.pw>
pkgname=protocase-designer
pkgver=6.0
-pkgrel=1
+pkgrel=2
pkgdesc="The fastest and easiest way to design, price, and build custom electronics enclosures."
arch=('x86_64')
url="http://www.protocasedesigner.com/"
@@ -17,21 +17,28 @@ md5sums=('SKIP'
'SKIP')
package() {
-
+ # new version uses a packaged JVM, ready for use
install -d $pkgdir/usr/local/lib/
- cp -R $srcdir/ProtocaseDesigner/ProtocaseDesigner $pkgdir/usr/local/lib
- install -d $pkgdir/usr/local/share/ProtocaseDesigner/
- cp -R $srcdir/ProtocaseDesigner/library $pkgdir/usr/local/share/ProtocaseDesigner/
+ install -d $pkgdir/usr/local/bin/
+ install -d $pkgdir/opt/ProtocaseDesigner/
install -d $pkgdir/usr/local/share/pixmaps/
+ install -d $pkgdir/usr/local/share/applications/
+
+ # copy everything to /opt/ProtocaseDesigner
+ cp -R $srcdir/ProtocaseDesigner $pkgdir/opt/
+
+ # create the shortcut
+ cp $srcdir/ProtocaseDesigner/ProtocaseDesigner.desktop $pkgdir/usr/local/share/applications/ProtocaseDesigner.desktop
cp $srcdir/ProtocaseDesigner/Protocase-Designer.png $pkgdir/usr/local/share/pixmaps/Protocase-Designer.png
- install -d $pkgdir/usr/local/bin/
+ # add a shell script to run said files
echo '#/bin/sh' > $pkgdir/usr/local/bin/ProtocaseDesigner
echo "install -d ~/ProtocaseDesigner/" >> $pkgdir/usr/local/bin/ProtocaseDesigner
- echo "mkdir ~/ProtocaseDesigner/UserLibrary" >> $pkgdir/usr/local/bin/ProtocaseDesigner
- echo "LD_LIBRARY_PATH=/usr/local/lib/ProtocaseDesigner/:/usr/local/lib/ProtocaseDesigner/lib/:\ $LD_LIBRARY_PATH java -jar /usr/local/lib/ProtocaseDesigner/ProtocaseDesigner.jar >> ~/ProtocaseDesigner/error.log 2>&1" >> $pkgdir/usr/local/bin/ProtocaseDesigner
- chmod 755 $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "mkdir -p ~/ProtocaseDesigner/UserLibrary" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ echo "LD_LIBRARY_PATH=/opt/ProtocaseDesigner/natives/occjava/linux-x86_64 /opt/ProtocaseDesigner/ProtocaseDesigner" >> $pkgdir/usr/local/bin/ProtocaseDesigner
+ chmod +x $pkgdir/usr/local/bin/ProtocaseDesigner
+
+ # make an alias protocase-designer
+ ln -s $pkgdir/usr/local/bin/ProtocaseDesigner $pkgdir/usr/local/bin/protocase-designer
- install -d $pkgdir/usr/local/share/applications/
- cp $srcdir/ProtocaseDesigner.desktop $pkgdir/usr/local/share/applications/ProtocaseDesigner.desktop
}