summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Down2022-08-12 02:19:01 +0100
committerChris Down2022-08-12 02:19:01 +0100
commit427b5b938fd01a24786392583e53bb1e8b79fb36 (patch)
tree8515d5d565c57ab669ff957002b3252321371c68 /PKGBUILD
parent7c59f223cd6151c6e169fa8d09471524a1920667 (diff)
downloadaur-psi-notify-git.tar.gz
upgpkg: psi-notify-git 1.3.0.r7.g0eea074-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc9075f5ac9a..e875c6a5823a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=psi-notify-git
_gitname=psi-notify
-pkgver=1.2.1.r11.gd6f6368
+pkgver=1.3.0.r7.g0eea074
pkgrel=1
pkgdesc='Minimalistic PSI notifier using libnotify (git version)'
url="https://github.com/cdown/psi-notify"
@@ -12,7 +12,7 @@ depends=(libnotify)
provides=(psi-notify)
conflicts=(psi-notify)
makedepends=(git)
-source=(git+https://github.com/cdown/psi-notify.git)
+source=('git+https://github.com/cdown/psi-notify.git')
md5sums=('SKIP')
pkgver() {
@@ -21,12 +21,10 @@ pkgver() {
}
build() {
cd -- "$_gitname"
- make
+ make prefix="/usr"
}
package() {
- mkdir -p "$pkgdir"/usr/bin "$pkgdir"/usr/lib/systemd/user
- cp -a "${srcdir?}/$_gitname"/psi-notify "$pkgdir"/usr/bin
- cp -a "${srcdir?}/$_gitname"/psi-notify.service \
- "$pkgdir"/usr/lib/systemd/user
+ cd -- "$_gitname"
+ make prefix="/usr" DESTDIR="$pkgdir/" install
}