summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2024-03-20 14:51:14 +0100
committerNicolas Iooss2024-03-20 14:51:14 +0100
commit2506dafc9f04a4beecc1ea6dea86bacce9f375ed (patch)
tree6d804c32e3d91ea3101b1c0d868dbe5407ad865e /PKGBUILD
parent100bb933436bae1e9e1be6118cf258f578b55828 (diff)
downloadaur-psmisc-selinux.tar.gz
psmisc-selinux 23.7-1 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fb063062085f..4814207e906b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=psmisc-selinux
-pkgver=23.6
+pkgver=23.7
pkgrel=1
pkgdesc='Miscellaneous procfs tools with SELinux support'
arch=('x86_64' 'aarch64')
@@ -15,16 +15,22 @@ url='https://gitlab.com/psmisc/psmisc'
license=('GPL')
groups=('selinux')
depends=('ncurses' 'libselinux')
+makedepends=('git' 'po4a')
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
validpgpkeys=('5D2FB320B825D93904D205193938F96BDF50FEA5') # Craig Small <csmall@debian.org>
-source=("https://downloads.sourceforge.net/psmisc/${pkgname/-selinux}-${pkgver}.tar.xz"{,.asc})
-sha256sums=('257dde06159a4c49223d06f1cccbeb68933a4514fc8f1d77c64b54f0d108822a'
- 'SKIP')
+source=("git+https://gitlab.com/psmisc/psmisc.git#tag=v${pkgver}?signed")
+sha256sums=('80ae6e626ba83232b7af1c02f3f528834ebdd96325367b701f69125d3e196f2f')
+
+prepare() {
+ cd ${pkgname/-selinux}
+
+ ./autogen.sh
+}
build() {
- cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
+ cd ${pkgname/-selinux}
./configure \
--prefix=/usr \
@@ -33,7 +39,7 @@ build() {
}
package() {
- cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
+ cd ${pkgname/-selinux}
make DESTDIR="${pkgdir}" install
}