summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2018-03-10 10:39:47 +0100
committerMichel Zou2018-03-10 10:39:47 +0100
commit20e03a0f720166cbbbea86601ffcca253a6dbe3b (patch)
tree9776cc3142197fe4aa653633a05e31c8bc0189d0 /PKGBUILD
parent96b481d0bf6c7b8496ed1bf44eb73fb6d44a9fe6 (diff)
downloadaur-psp-openal.tar.gz
unpatch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 2 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 327471ffa051..4cdb9ae3908e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,26 +14,14 @@ md5sums=('3d8b86c21a2f87a2a5e60f78f3b3f03d')
prepare() {
cd "$srcdir"/openal-soft-$pkgver
-
- # FIXME: -lc should be put after -lm, and libm is not detected
- sed -i "s|CHECK_LIBRARY_EXISTS(m pow|set(HAVE_LIBM TRUE)#CHECK_LIBRARY_EXISTS(m pow|g" CMakeLists.txt
-
# from https://github.com/pspdev/psplibraries/blob/master/scripts/openal.sh
- sed -i -e "s/memory\.h/string.h/" Alc/*.c Alc/backends/*.c
-
- # find pthread in pthread-psp
- sed -i "s|CHECK_LIBRARY_EXISTS(pthread|CHECK_LIBRARY_EXISTS(pthread-psp|g" CMakeLists.txt
- sed -i "s|SET(EXTRA_LIBS pthread|SET(EXTRA_LIBS pthread-psp|g" CMakeLists.txt
-
- # need to link these
- sed -i "346iset(CMAKE_REQUIRED_LIBRARIES pspdebug pspdisplay pspge pspsdk c pspuser)" CMakeLists.txt
- sed -i "346iset(EXTRA_LIBS \${EXTRA_LIBS} pspdebug pspdisplay pspge pspsdk c pspuser)" CMakeLists.txt
+ #sed -i -e "s/memory\.h/string.h/" Alc/*.c Alc/backends/*.c
}
build() {
cd "$srcdir"/openal-soft-$pkgver
mkdir -p build-psp && pushd build-psp
- psp-cmake -DPKG_CONFIG_EXECUTABLE=/usr/psp/bin/pkg-config -DCMAKE_VERBOSE_MAKEFILE=1 ..
+ psp-cmake -DPKG_CONFIG_EXECUTABLE=/usr/psp/bin/pkg-config -DUTILS=OFF ..
make
}