summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAshley Ruglys2020-02-25 16:03:52 +0100
committerAshley Ruglys2020-02-25 16:03:52 +0100
commit4041e8a3f1e50747c8e7141696e3cb2a50ab5b6b (patch)
treeb8d3397eb150c36ab76176a5f4d4b877016c52da /PKGBUILD
downloadaur-pumba-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..482f140b5b30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ashley Ruglys <ashley.ruglys@gmail.com>
+pkgname=pumba-git
+_pkgname=pumba
+pkgdesc="Chaos testing tool for Docker"
+pkgrel=1
+pkgver=0.7.1
+arch=('i686' 'x86_64')
+provides=("pumba")
+url="https://github.com/alexei-led/pumba/releases"
+license=('APACHE')
+depends=()
+makedepends=('go')
+source=("$_pkgname::git+https://github.com/alexei-led/pumba")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ cat VERSION
+}
+
+build() {
+ cd $_pkgname
+ ./hack/build.sh
+}
+
+package() {
+ cd $_pkgname
+ install -D -m755 "$srcdir/$_pkgname/.bin/pumba" "$pkgdir/usr/bin/pumba"
+}