summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlbert Graef2022-08-04 03:31:09 +0200
committerAlbert Graef2022-08-04 03:33:37 +0200
commit7c18ded1bc58e3ad5955e342942a19ac75ee5c53 (patch)
tree98a76362dbb296588b919ba71d8de1af0ff7b0fb /PKGBUILD
parent0683907ed13a9b193d6bd5cb5b3dbf2ca8a472db (diff)
downloadaur-pure-pcre.tar.gz
Fixes for Emacs 27 compatibility.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0170294f8092..6dbc0f5e76f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=pure-pcre
_pkgname=pure
pkgver=0.68
-pkgrel=3
+pkgrel=4
pkgdesc="Pure is a modern-style functional programming language based on term rewriting (variant with Perl regex support)."
arch=("i686" "x86_64")
license=('GPL3' 'LGPL3')
@@ -21,8 +21,15 @@ optdepends=("clang35: needed for inlining C/C++ code"
"texmacs-pure: embedding Pure sessions in TeXmacs")
provides=('pure')
conflicts=('pure')
-source=("https://github.com/agraef/pure-lang/releases/download/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz")
-md5sums=('082d522d05e58e55dc8094ba4c3d3eda')
+source=("https://github.com/agraef/pure-lang/releases/download/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz"
+ "emacs27.patch")
+md5sums=('082d522d05e58e55dc8094ba4c3d3eda'
+ 'fe62166e277a6accefbfa81e2e307900')
+
+prepare() {
+ cd $srcdir/$_pkgname-$pkgver
+ patch -p2 -i ../emacs27.patch
+}
build() {
cd $srcdir/$_pkgname-$pkgver