summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2024-03-12 14:00:40 -0400
committerSolomon Choina2024-03-12 14:00:40 -0400
commitee3a30d188bb32b0470f7c146b10da606aa5a000 (patch)
tree8285e499d76fefa88af8b88b7c21a345413faed7 /PKGBUILD
parent54032aabc7de44830b9e322982fe7cb3a88f05f0 (diff)
downloadaur-purpose-git.tar.gz
update packages
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 25 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5d735d6eb7ce..1117cbbc9cf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,34 @@
pkgname=purpose-git
_name=${pkgname/-git}
-pkgver=r1232.68918bd6
+pkgver=r1238.ef7dace8
pkgrel=1
pkgdesc="Framework for providing abstractions to get the developer's purposes fulfilled"
arch=(x86_64)
url='https://projects.kde.org/projects/playground/libs/purpose'
-license=('CC0-1.0' 'LGPL-2.1-or-later')
-depends=(kio-git kaccounts-integration-git kirigami2-git accounts-qml-module prison-git)
-makedepends=(extra-cmake-modules-git git python intltool kdeclarative-git qt6-multimedia)
+license=(LGPL-2.0-only LGPL-3.0-only)
+depends=(accounts-qml-module
+ gcc-libs
+ glibc
+ kaccounts-integration
+ kcmutils
+ kconfig
+ kcoreaddons
+ ki18n
+ kio
+ kirigami
+ knotifications
+ kservice
+ libaccounts-qt
+ qt6-base
+ qt6-declarative
+)
+makedepends=(extra-cmake-modules git python intltool kdeclarative qt6-multimedia prison)
+optdepends=('bluez-qt: sharing via Bluetooth'
+ 'kdeclarative: Nextcloud and YouTube plugins'
+ 'kdeconnect: sharing to smartphone via KDE Connect'
+ 'prison: QR code plugin'
+ 'telegram-desktop: sharing via Telegram')
provides=(purpose)
conflicts=(purpose)
source=("git+https://github.com/KDE/$_name.git")
@@ -22,7 +42,7 @@ pkgver() {
}
build() {
- cmake -B build -S $_name
+ cmake -B build -S $_name -DCMAKE_INSTALL_LIBEXECDIR=lib -DBUILD_TESTING=OFF
cmake --build build
}