summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormorganamilo2021-06-18 12:55:13 +0100
committermorganamilo2021-06-18 12:55:55 +0100
commit7fd203df97e4e22b262165d88217084c63219457 (patch)
tree8488fe1392d6ac2b5044f8b960836f713d7dd90f /PKGBUILD
parentab29a2f9e51099c29ce1215313e14a0ab81b64fd (diff)
downloadaur-putils-git.tar.gz
update pkgbuild
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1217f723b464..00513b135a07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Anna <morganamilo@gmail.com>
+# Maintainer: Morganamilo <morganamilo@gmail.com>
_pkgname=putils
pkgname=putils-git
-pkgver=r3.1e54e08
+pkgver=r3.7f4ccee
pkgrel=1
pkgdesc="Utilities for working with pipes"
arch=(x86_64)
url="https://github.com/Morganamilo/putils"
license=('GPL3')
+depends=(glibc)
makedepends=(git go asciidoc)
provides=(putils)
conflicts=(putils)
@@ -14,6 +15,12 @@ source=("git+https://github.com/Morganamilo/putils")
md5sums=('SKIP')
build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" all
}