summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Hu2015-06-30 13:13:18 +0100
committerNick Hu2015-06-30 13:13:18 +0100
commit18c5160f1d49f36ab6dbf9cb9f880c85549bf458 (patch)
tree27778c539fb275c1e9ec4895db0522e0fa5fe076 /PKGBUILD
downloadaur-puush.tar.gz
AUR4 migration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df56948db0d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nick Hu <nickhu00@gmail.com>
+pkgname=puush
+pkgver=1.2
+pkgrel=1
+pkgdesc="A bash script to upload to and delete from puush.me"
+arch=(any)
+url="https://github.com/NickHu/puush-linux"
+license=('MIT')
+depends=(curl bash)
+optdepends=('scrot: screenshot tool')
+install=puush.install
+source=(https://github.com/NickHu/puush-linux/archive/v${pkgver}.tar.gz)
+md5sums=('cbcbed1b7dc21691d02b81393af52f0c')
+
+package() {
+ cd "$srcdir/$pkgname-linux-$pkgver"
+ install -Dm 755 puush $pkgdir/usr/bin/puush
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}