summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFlaviu Tamas2018-11-11 17:59:32 -0500
committerFlaviu Tamas2018-11-11 17:59:32 -0500
commita47ce30fe6f0fc4ea70b1707d215135dc58f80ec (patch)
tree3eb20ef7523287f51af85ea36a45d91ad4a9f76e /PKGBUILD
parent55b75c1f31a3af940348dc6748a9d50bbe35f26b (diff)
downloadaur-pylote.tar.gz
Deprecate package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f987bc6c648a..cd3f560c2cb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,18 @@
pkgname=pylote
pkgver=1.4
-pkgrel=4
+pkgrel=5
pkgdesc="Software making it possible to draw on the screen of the computer, like handling various instruments of geometry."
url="http://pascal.peter.free.fr/wiki/Logiciels/Pylote"
license=('GPL')
arch=('any')
depends=('pyqt')
-source=(http://pascal.peter.free.fr/wikiuploads/pylote.tar.gz $pkgname.desktop)
-sha256sums=('b5cfefa54057f42981773357d572e648bd08409f7a730b7aab6aac5dcbbb933b'
- '8557e071b14f22e5386715d4769aada56175fa8a266508ce42043363b30b0bd7')
+provides=(pylote)
+conflicts=(pylote)
+source=()
+sha256sums=()
package() {
- cd ${srcdir}/${pkgname}
- mkdir -p ${pkgdir}/usr/share/{$pkgname,applications}
- mkdir -p ${pkgdir}/usr/bin
- cp -R * ${pkgdir}/usr/share/$pkgname
- echo "#!/usr/bin/bash
- cd '/usr/share/pylote/' && python pylote.pyw" > ${pkgdir}/usr/bin/pylote
- chmod +x ${pkgdir}/usr/bin/pylote
- cp ${srcdir}/pylote.desktop ${pkgdir}/usr/share/applications
+ echo "please use pylote-git because the tarball is simply an un-versioned git snapshot"
+ return 1
}