summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastiaan Lokhorst2017-05-09 21:56:13 +0200
committerChristoph Brill2017-05-09 21:56:13 +0200
commit23a08c7421e66726fd6980f4e79e6d78fcc9f8f7 (patch)
tree302b5c833115819fe7f13f6ce293bf089e640538 /PKGBUILD
parent636eb669fc24a423b98fa87515032f80067c14a3 (diff)
downloadaur-pylotro-git.tar.gz
Switch to python3 as recommend by upstream
Clean up PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 11 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28c2d51b2028..717800e029f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
# Maintainer: Christoph Brill <egore911@gmail.com>
pkgname=pylotro-git
-pkgver=40
+pkgver=62
pkgrel=1
pkgdesc="LOTRO/DDO Launcher (needed to login to Turbine Inc. servers)"
-arch=('i386' 'x86_64')
-url="https://launchpad.net/~ajackson-bcs/+archive/ppa/"
+arch=('i686' 'x86_64')
+url="https://github.com/nwestfal/pylotro"
license=('GPL3')
-depends=('openal' 'python2-pyqt')
- if test "$CARCH" == x86_64; then
- depends+=('lib32-openal')
- fi
+depends=('openal' 'python-pyqt4')
+depends_x86_64=('lib32-openal')
makedepends=('git')
conflicts=('pylotro')
provides=('pylotro')
source=('pylotro-git::git+https://github.com/nwestfal/pylotro.git')
+md5sums=('SKIP')
-package() {
+pkgver() {
cd $srcdir/pylotro-git
- # Install files
- python2 setup.py install --root=$pkgdir
+ echo $(git rev-list --count master)
}
-pkgver() {
+package() {
cd $srcdir/pylotro-git
- echo $(git rev-list --count master)
+ # Install files
+ python setup.py install --root=$pkgdir
}
-
-md5sums=('SKIP')