summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2020-04-03 16:37:42 +0200
committerhaawda2020-04-03 16:37:42 +0200
commita50167e32d260559ef4ffe9543a84910febc76b3 (patch)
tree8eda7d9760f0d3a563b9b1a5d7acb681136bce50 /PKGBUILD
parent04d568dba307009c9019279f08691eb9c03c3158 (diff)
downloadaur-pymacs.tar.gz
use python, not python2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f78f5531cc9..834bf5ce696b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=pymacs
pkgver=0.26
-pkgrel=1
+pkgrel=2
pkgdesc='Interface between Emacs Lisp and Python.'
arch=('any')
url='https://github.com/dgentry/Pymacs'
license=('GPL2')
depends=('emacs')
-makedepends=('python2' 'python2-docutils' 'texlive-core')
+makedepends=('python' 'python-docutils')
conflicts=('emacs-python-mode')
source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
sha256sums=('e876a48a7540d45956fc1c3e623efe638a2093a580c9ab591ebceed0cd7bc707')
@@ -18,14 +18,14 @@ install=$pkgname.install
build() {
cd ${pkgname//p/P}-${pkgver}
- make PYTHON=python2 PREFIX=/usr
+ make PREFIX=/usr
emacs -batch -f batch-byte-compile pymacs.el
- python2 ./setup.py build
+ python ./setup.py build
}
package() {
cd ${pkgname//p/P}-${pkgver}
- python2 ./setup.py install --prefix="$pkgdir"/usr
+ python ./setup.py install --prefix="$pkgdir"/usr
install -d "$pkgdir"/usr/share/emacs/site-lisp
install -m 644 $pkgname.{el,elc} "$pkgdir"/usr/share/emacs/site-lisp
}