summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122021-06-25 14:31:33 +0200
committerwillemw122021-06-25 14:31:33 +0200
commit7839222ba113a2ca6313638e78d9fbad5acb83db (patch)
treeda20917f3bb6c426a661817c7cbfb43a851e268f /PKGBUILD
parent6438ec1f14f759269ed39153a36e1bfce96ebebc (diff)
downloadaur-7839222ba113a2ca6313638e78d9fbad5acb83db.tar.gz
Remove ncurses, python
Change "install -D". Minor edits.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f80954d170c3..9d599f6f2e59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,13 +9,13 @@ pkgdesc="Internet radio player for the command line"
arch=('any')
url="http://www.coderholic.com/pyradio/"
license=('MIT')
-depends=('ncurses' 'python' 'python-requests' 'python-dnspython')
-optdepends=('mplayer: as backend' 'vlc: as backend' 'mpv: as backend')
+depends=('python-dnspython' 'python-requests')
+optdepends=('mplayer: as backend' 'mpv: as backend' 'vlc: as backend')
makedepends=('git' 'python-setuptools')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=($pkgname::git+https://github.com/coderholic/pyradio.git)
-md5sums=('SKIP')
+sha256sums=('SKIP')
prepare() {
cd $pkgname
@@ -32,13 +32,10 @@ pkgver() {
package() {
cd $pkgname
+ #install -Dm644 LICENCE -t "$pkgdir/usr/share/licenses/pyradio"
install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
-
- install -dm755 "$pkgdir/usr/share/doc/pyradio"
- install -m644 README.{html,md} build.{html,md} "$pkgdir/usr/share/doc/pyradio"
-
- install -dm755 "$pkgdir/usr/share/man/man1"
- install -Dm644 pyradio.1 "$pkgdir/usr/share/man/man1/${pkgname%-git}.1"
+ install -Dm644 README.{html,md} build.{html,md} -t "$pkgdir/usr/share/doc/pyradio"
+ install -Dm644 pyradio.1 -t "$pkgdir/usr/share/man/man1"
python setup.py install --root="$pkgdir" --optimize=1
}