summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTrougnouf (Benoit Brummer)2024-04-02 23:33:46 +0200
committerTrougnouf (Benoit Brummer)2024-04-02 23:33:46 +0200
commit206131bbd17a05341662909793105c3d3934d5e6 (patch)
tree061ef3ce95ccec7e4a2f770780f24cc075869a5b /PKGBUILD
downloadaur-pysuntimes-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7be5405c5b57
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Trougnouf (Benoit Brummer) <trougnouf@gmail.com>
+
+_name=pysuntimes
+pkgname=("${_name}-git")
+pkgver=r3.16c6fdf
+pkgrel=1
+pkgdesc="Print suntimes given a date and a set of coordinates. (civil/nautical/astronomical twilights, sunset/sunrise, and golden hours)"
+arch=('any')
+url="https://github.com/trougnouf/${_name}"
+license=('GPL')
+depends=('python-pyephem' 'python-timezonefinder' 'python-pytz')
+provides=("python-${_name}")
+conflicts=("python-${_name}")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/$_name"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_name}"
+ mkdir -p "${pkgdir}/usr/bin/"
+ cp suntimes.py "${pkgdir}/usr/bin/"
+ chmod +x "${pkgdir}/usr/bin/suntimes.py"
+}
+