summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquim Monteiro2024-04-22 05:12:56 +0100
committerJoaquim Monteiro2024-04-22 05:46:55 +0100
commit5cacdee7f7137ac8e0d2394c0a2bfdf7fab92ba4 (patch)
tree83d324d808f709b09c250c83db217f65a0d5a739 /PKGBUILD
parent9c332d5145bd923e663fce89376b11e60d4e5751 (diff)
downloadaur-python-aiohttp-proxy.tar.gz
Migrate to standards based build and rebuild for Python 3.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d9165a1756a2..ad71981dfc26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,25 @@
_commit="8810ab6c0daf9f537f2c2bb1ce049fbdae7b9f6e"
pkgname=python-aiohttp-proxy
pkgver=0.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="SOCKS proxy connector for aiohttp. HTTP, HTTPS, SOCKS4(a) and SOCKS5(h) proxies are supported."
arch=(any)
url="https://github.com/Skactor/aiohttp-proxy"
-license=("Apache")
+license=("Apache-2.0")
depends=("python" "python-aiohttp")
-makedepends=("python-setuptools")
+makedepends=("python-build" "python-installer" "python-setuptools" "python-wheel")
source=("aiohttp-proxy-${pkgver}::git+https://github.com/Skactor/aiohttp-proxy#commit=${_commit}")
sha512sums=("SKIP")
+build() {
+ cd "aiohttp-proxy-${pkgver}"
+ [[ -d dist/ ]] && rm -f dist/*.whl
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "aiohttp-proxy-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}