summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquim Monteiro2024-04-22 05:19:02 +0100
committerJoaquim Monteiro2024-04-22 05:47:42 +0100
commitcd09afdf21e546c866581f20b0baa282687590ff (patch)
treebfa31f0b7d8ce302a9d0234838d7d9932bbcc8a3 /PKGBUILD
parentcc9f0d185469952f27aea69bf2c9f5f9951d8784 (diff)
downloadaur-python-aiohttp-proxy-git.tar.gz
Migrate to standards based build and rebuild for Python 3.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14e9979d1192..d8cfa6d2c204 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: gmes78 <gmes.078 at gmail dot com>
pkgname=python-aiohttp-proxy-git
-pkgver=v0.1.1.r0.g131c0e4
-pkgrel=1
+pkgver=v0.1.1.r6.g8810ab6
+pkgrel=2
pkgdesc="SOCKS proxy connector for aiohttp. HTTP, HTTPS, SOCKS4(a) and SOCKS5(h) proxies are supported. (Git version)"
arch=(any)
url="https://github.com/Skactor/aiohttp-proxy"
-license=("Apache")
+license=("Apache-2.0")
depends=("python" "python-aiohttp")
-makedepends=("git" "python-setuptools")
+makedepends=("git" "python-build" "python-installer" "python-setuptools" "python-wheel")
provides=("python-aiohttp-proxy")
conflicts=("python-aiohttp-proxy")
@@ -21,7 +21,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "aiohttp-proxy"
+ [[ -d dist/ ]] && rm -f dist/*.whl
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "aiohttp-proxy"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}