summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquim Monteiro2024-04-22 05:27:41 +0100
committerJoaquim Monteiro2024-04-27 17:00:30 +0100
commitf7247b28b9ecdf98452a33cff73c113b6b7f030b (patch)
treec296b9591664ecfa2f024d7a865a1e9df461f5b8 /PKGBUILD
parent0b1f6d9cb2c1a50b3fdc594c322f8246084472a3 (diff)
downloadaur-python-aiohttp-socks-git.tar.gz
Migrate to standards based build and rebuild for Python 3.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77d1152d0cba..470ef6d384f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: gmes78 <joaquim dot monteiro at protonmail dot com>
+# Maintainer: Joaquim Monteiro <joaquim dot monteiro at protonmail dot com>
pkgname=python-aiohttp-socks-git
-pkgver=v0.7.0.r0.g6936737
-pkgrel=1
+pkgver=v0.8.4.r0.gadb9bb0
+pkgrel=2
pkgdesc="Proxy connector for aiohttp. Supports SOCKS4(a), SOCKS5, HTTP (tunneling) as well as proxy chains. (Git version)"
arch=(any)
url="https://github.com/romis2012/aiohttp-socks"
-license=("Apache")
+license=("Apache-2.0")
depends=("python" "python-aiohttp" "python-python-socks")
-makedepends=("git" "python-setuptools")
+makedepends=("git" "python-build" "python-installer" "python-setuptools" "python-wheel")
provides=("python-aiohttp-socks")
conflicts=("python-aiohttp-socks")
@@ -21,7 +21,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "aiohttp-socks"
+ [[ -d dist/ ]] && rm -f dist/*.whl
+ python -m build --wheel --no-isolation
+}
+
package() {
cd "aiohttp-socks"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}