summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGustav Sörnäs2024-03-18 14:03:25 +0100
committerGustav Sörnäs2024-03-18 14:03:25 +0100
commit41b8a3b64c3617e1cf24b0ea7c9969865719cb56 (patch)
treeaa2d964a05ca834e7b018cddd11fc4dca287f414 /PKGBUILD
parent638867389ec230285ed1d64f1107cf443f94325c (diff)
downloadaur-python-aiohttp-sse.tar.gz
upgpkg: 2.2.0-3: correct dir name
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8aa442a46813..85ddfd52712e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# vim: ts=2 sw=2 et:
pkgname=python-aiohttp-sse
+_pkgname=aiohttp-sse
pkgver=2.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="Server-sent events support for aiohttp"
arch=('x86_64')
url="https://github.com/aio-libs/aiohttp-sse"
@@ -16,16 +17,16 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
sha256sums=('SKIP')
build() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$pkgver
python -m build --wheel --no-isolation
}
check() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$pkgver
PYTHONPATH="$PWD/build/lib/" pytest
}
package() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
}