summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDJ Lucas2020-01-08 01:05:21 -0600
committerDJ Lucas2020-01-08 01:05:21 -0600
commitc321a1e0e45ab31972489c949a967aa16b4e7821 (patch)
tree5e67a91bf4ceeb41ef7b31460cbb3f557299111c /PKGBUILD
parent953b0e91d60194dad53ff7bf7d636751cc755c80 (diff)
downloadaur-python-aiohttp_remotes.tar.gz
Work around flit/pip installation issues.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d2b77262a1e3..cca975ab1a96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=('python-aiohttp_remotes')
pkgver=0.1.2
-pkgrel=2
+pkgrel=3
pkgdesc="A set of useful tools for aiohttp.web server"
pkgrelname='aiohttp_remotes'
pkgtar='aiohttp-remotes'
url="https://github.com/aio-libs/${pkgtar}"
arch=('x86_64')
license=('BSD')
+depends=('python-aiohttp'
+ 'python-yarl')
makedepends=('flit')
-depends=('python-aiohttp')
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=('074fc7d7dc7c07b653e202d44be46db87d35e95c77535417b78fc9b01d774b5d')
@@ -21,6 +22,6 @@ build() {
package() {
cd "${srcdir}/${pkgtar}-${pkgver}"
- pip install "dist/${pkgrelname}-${pkgver}-py3-none-any.whl" --root "${pkgdir}"
+ pip install -I --no-warn-script --isolated --no-deps --compile --root="${pkgdir}" "dist/${pkgrelname}-${pkgver}-py3-none-any.whl"
}
# vim:set ts=4 sw=4 et: