summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2024-03-05 04:18:08 +0800
committerlilac2024-03-05 04:18:08 +0800
commitdd9a2c9f3f259bc6c41797eb6a820def6a8d3b4d (patch)
treefb30d863e7dc83b694903dcf62cd298051718f75 /PKGBUILD
parent384fc8c018265be3ebf402fe356db7fe85ccc7e8 (diff)
downloadaur-python-aioice.tar.gz
[lilac] updated to 0.9.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f3038e7582c..5522053486f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,20 @@
_pkgname=aioice
pkgname=python-aioice
pkgver=0.9.0
-pkgrel=1
+pkgrel=3
pkgdesc='asyncio-based Interactive Connectivity Establishment (RFC 5245)'
arch=('any')
url='https://github.com/aiortc/aioice'
-license=('BSD')
+license=('BSD-3-Clause')
depends=(
python-dnspython
python-netifaces
)
makedepends=(
+ python-build
+ python-installer
python-setuptools
+ python-wheel
)
source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/aiortc/aioice/archive/refs/tags/${pkgver}.tar.gz")
@@ -21,12 +24,12 @@ sha512sums=('977669c80e93492743694630b3428a4fc617419381245b0a7b5527de8035b3103cb
build() {
cd "${_pkgname}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: