summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Langlois2020-10-15 17:12:10 -0400
committerEric Langlois2020-10-15 17:12:10 -0400
commitd472ee4a44d186b38cc489c91f6bbab7a6bd2376 (patch)
treef13f582fd33fe79d11bca503f100219f31f14c5c /PKGBUILD
parentf9facda434ad510db2aef8a3b4ea04afdc38daf5 (diff)
downloadaur-python-akro.tar.gz
upgpkg: python-akro 0.0.8-1
Patch akro tests to work without tensorflow.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83e9b581bd6c..e8d487f27c5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,8 +19,15 @@ checkdepends=(
'python-pytest-cov'
'python-pytest-xdist'
)
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('4fc0dc1acf35db19b39a209e20ce14dc8197723c73d3adf3ba7f8cdc1dbf6e58')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
+ "$_name-fix-test-imports.patch")
+sha256sums=('4fc0dc1acf35db19b39a209e20ce14dc8197723c73d3adf3ba7f8cdc1dbf6e58'
+ '7fa5b22dec473c540c9962143ab90f6dbf3487f1909b7aa7cdd2d34fb7e2343d')
+
+prepare() {
+ cd "$_name-$pkgver"
+ patch -p1 -i "$srcdir/$_name-fix-test-imports.patch"
+}
build() {
cd "$_name-$pkgver"